WSUS 3.0 SP2 & KB2734608

I'm only posting this because it through me for a loop for about a day and no other resource online had this as the solution. If you have a system running Server '12(r2) or Windows 8(.1) that pulls from WSUS and are receiving the Error Code 800B0001 then you'll need to install KB2734608 on you WSUS server.

This update lets servers that are running Windows Server Update Services (WSUS) 3.0 SP2 provide updates to computers that are running Windows 8 or Windows Server 2012.
— KB2734608